Error Updating Report on Power BI Service

I have published the report to the PowerBi Service. In Desktop all updates fine, in Service I get the error below. I have looked online and made sure the the settings are identical between desktop and service.

I connect to an odata which seems to work in both versions and to onedrive where 2 excelsheets are available.
I make an append query from data fro the odata and the onedrive. I read that this also might cause a problem.

Anybody that can help me with this?

Data source error: {“error”:{“code”:“ModelRefresh_ShortMessage_ProcessingError”,“pbi.error”:{“code”:“ModelRefresh_ShortMessage_ProcessingError”,“parameters”:{},“details”:[{“code”:“Message”,“detail”:{“type”:1,“value”:“Information is needed in order to combine data”}}],“exceptionCulprit”:1}}} Table: Sales.
Cluster URI: WABI-WEST-EUROPE-D-PRIMARY-redirect.analysis.windows.net
Activity ID: 555c1243-8027-4e4e-a6f1-c2214f618379
Request ID: a6eae0c9-c32e-4838-c1c4-e161d0892835
Time: 2020-06-17 18:31:45Z

Hi @elmer, we aim to consistently improve the topics being posted on the forum to help you in getting a strong solution faster. While waiting for a response, here are some tips so you can get the most out of the forum and other Enterprise DNA resources.

  • Use the forum search to discover if your query has been asked before by another member.

  • When posting a topic with formula make sure that it is correctly formatted to preformated text </>.

  • Use the proper category that best describes your topic

  • Provide as much context to a question as possible.

  • Include demo pbix file, images of the entire scenario you are dealing with, screenshot of the data model, details of how you want to visualize a result, and any other supporting links and details.

I also suggest that you check the forum guideline How To Use The Enterprise DNA Support Forum. Not adhering to it may sometimes cause delay in getting an answer.

Hi @elmer,

If you have already append or combine two or more tables you should do it in a new query instead of the main query.

also if there is anything in the recent month update that might have affected the data privacy settings with the reports then follow this procedure below:

  • Open .pbix report in Power BI Desktop
  • File - Options & Settings - Data Source Settings --> Clear All Permissions
  • File - Options and Settings - Option --> Clear Cache in “Date Cache Management” and “Q&A Cache Options”
  • Home - Refresh --> keep track of how you log into each data source. In my case it was 3 sources, all Organizational privacy levels
  • Save and Publish the report
  • Go to data source in the PBI service, and re-login to each of the data sources under Data Source Credentials --> set the same privacy level as the desktop app

Also you can read more helpful tips in this link below too:

If you need any further help kindly don’t hesitate to get back and ask, and if this help kindly make it a solution for others

DAVID

2 Likes

Hi David,

Did just that but to no avail.

I am trying to login to Onedrive. From my desktop it seems to be working differently then from the service. Most likely this is where I make a mistake.

What is the best way to login to One Drive? It is a personal Sharepoint. On service authentication method is OAUTH2 organisational, on desktop it is organzational and I pick my account for logging in

Hi @elmer, a response on this post has been tagged as “Solution”. If you have a follow question or concern related to this topic, please remove the Solution tag first by clicking the three dots beside Reply and then untick the check box. Also, we’ve recently launched the Enterprise DNA Forum User Experience Survey, please feel free to answer it and give your insights on how we can further improve the Support forum. Thanks!