Date Slicer Format Issue

Hi All,

I seem to be having an issue with my date slicer. For some reason, it defaults to the American format (MM/DD/YYYY).

I’ve looked online in the forums for solutions to fix this and the only suggestions that come are changing the browser language and locale which I have done, however, the date slicer still will not change.

Since changing the browser language pack, the Data Updated section shows the correct format but the slicer does not (see screenshot)

Anu suggestions on how to rectify this?

Thanks

Q: Did you check the date format in the date column and made sure it’s set to dd/MM/yyyy

also

The issue can be caused by a combination of the settings in the Power BI Service and settings in your browser. Seems you’ve already checked the browser but did you also check the Power BI service?
1) Click on the gear icon in the top right corner
2) Click on Settings
image
3) Select Language
4) Select Default Browser Language

I hope this is helpful.

@Melissa Thanks for the response.

I’ve tried all of the things you suggested as this was what was also posted online. However the dates still default to the American Format.

Any other suggestions?

@adsa,

Its likely your own setting on your computer.
You can change your setting there. Any program that you are running will take your computer settings.

click on Change Data format

I hope this helps.

Thanks
Keith

Hello @adsa,

Thank You for posting your query onto the Forum.

I’ve created a similar situation that you’re facing in your browser. Firstly, I have attached below the screenshot of the date slicer under the “MM/DD/YYYY” format.

Date Slicer Format - 1

Now, below are the steps provided that you’ll be required to perform to convert the date slicer format from “MM/DD/YYYY” to “DD/MM/YYYY”.

Step 1: In the Google Chrome, click on the 3 dots ellipses and go to the "Settings menu. Below is the screenshot provided for the reference.

image

Step 2: Under the search bar, type “Languages”. Below is the screenshot provided for the reference.

Step 3: Select the add languages option. Below is the screenshot provided for the reference.

Date Slicer Format - 4

Step 4: Type the “English” and select the desired language. Below is the screenshot provided for the reference.

Step 5: Click on the 3 dots ellipses adjacent to the language newly added and select it as you default language. Below is the screenshot provided for the reference.

Step 6: Select the “Relaunch” option. Below is the screenshot provided for the reference.

Now, go back to your report and refresh it, if required, and you shall the the “DD/MM/YYYY” in your date slicer. Below is the screenshot provided for the reference.

Date Slicer Format - 8

Hoping you find this useful and helps you to convert the date slicer in the desired date format that you’re looking. :slightly_smiling_face:

Thanks and Warm Regards,
Harsh

@Keith thanks for the response. I’ve checked all of those settings and unless I’m missing something they all seem to be in order.

In the desktop version it is exactly how it should be. It seems to be an issue only in the PowerBI service.

Hi @adsa
Your slicer looks right to me that its July 1 to aug 20 compared. its setup for dd/mm/yyyy as per your system.

You know you change that format on the computer to read mm/dd/yyyy by clicking on Change data format. If that’s what you want.

Keith

@Keith Thanks Keith. @Harsh method worked. I use Firefox and had to change the language in 2 places.

@adsa, welcome.

Maybe, you can put up the steps that you had to do. It might help the rest of the group if someone else has the same issue that you encountered.
thanks
Keith

Hello @adsa,

You’re Welcome. :slightly_smiling_face:

I’m glad I was able to help you.

Thanks and Warm Regards,
Harsh

For Firefox (Solution):

Step 1: Options:

image

Step 2: Language

I selected English UK as there was no English Australia and also made sure that the language in regional settings in Windows (See @Keith post above) was set to English Australia

image

Step 3: Log out of PowerBI service and back in.