Latest Enterprise DNA Initiatives

Creating Key Measure Table on my model

Hi everyone,

I have not followed the very latest changes but I am building a data model and am trying to create the usual “Key Measures” folder to keep all the measures in one place. However, I am not able to delete the single column that exists in the table so that the folder turns to key measures folder and as such it appears as a table in my model. Have there been some changes recently that I have missed?

I hope it makes sense.

None AFAIK … works fine and has worked fine for me in all recent versions of PBI Desktop (including 2.85.985.0 this morning…)

Thank you, @Greg. Are you using an old file? I have it in my other files and it is fine. However, building this new data model is not showing me the option. Here is a screenshot where the delete option is not available.

Both existing and new … I just did it again in a brand new file with no issues …

eDNA Forum - Key Measures Table Check.pbix (17.3 KB)

That is strange! I cant seem to have the delete option for the column. I wonder if my settings are somehow changed but I cant think of anything.

Baffling … I’ve never had this issue … can you reboot, check again, then if the issue persists, uninstall and re-install Power BI Desktop?

@Greg, here is the file. See if you can find anything in it.
AR Aging.pbix (310.3 KB)

See if you can delete the empty column under the key measures. If you can, then it is definitely something wrong my desktop version so might reinstall it.

You don’t have to delete that column…
Just right-click and ‘Hide’ it, then it will also show up as a Measure table once you’ve clicked Show/Hide Fields pane

Thanks, @Melissa. I did that too but the shape of the group still looks like a table as opposed to what usually happens and it changes to measure icon.

So it looks like you’ve entered a calculated table instead of using this option

If you use this to create the measure table, you can Hide or Delete that column without any issue


Per @Melissa’s earlier response, here’s a thread explaining why you should hide, rather than delete that column in your measures table:

  • Brian

Something is up with your measures table … I created a new measures table [Key Measures 2] and everything worked properly … still can’t see the delete option for your existing [Key Measures] table … go figure …

eDNA Forum - Measures Table Check 2 - AR Aging.pbix (281.3 KB)

Thank you, everyone. I think @Melissa was right. I had created a “New Table” rather than using enter data option. It looks fine now. Thanks again!