Workspace on pbi service not showing for an external user

Hi everyone,

I’ve published several reports (i have a pro license) in a workspace on BI Service and i want an external user (with a pro license too) to access this workspace as a viewer.

Here are the steps i followed :

1/ Azure : i created an new user via Microsoft Entra ID. I filled the email field* with his BI id (email address) :

2/ BI Service : in the tenant settings, all the basic authorizations have been activated for external users :

3/ BI Service workspace containing the report : the external user ID has been set to “Viewer”

4/ Microsoft Entra ID : an invitation was sent to the external user’s email address (Bi ID). He received the email and clicked on “Accept invitation” which redirected him to the web page “My apps” .

I don’t know if i’ve missed a step or a setting but when the external user in question logs in his pbi service, the workspace doesn’t show.

Do you have any advice, suggestions on how to show that workspace on his pbi service please ?

Many thanks