Latest Enterprise DNA Initiatives

WHY is it so difficult to LOG-IN as an existing member?

II haven’t visited in a whileand needed to today and kept going round and rond looking for a “MEMBER log-in”? Where has that gone?

NEXT, I get this "Our Policiy has changed and I must accept the new policies? WHERE is the expanation of what’s changed? So, I clicked on “Terms of Service” and it took me to some " TERMS of Serice with so lengthy legal language that I was NOT about to signn

Has EnterpriseDNA BEEN SOLD to and/or has yoyr excellent site been hijacked or something.

Color me VERY disappointed and confused as a “Lifetime MEMBER”.

Please explain !


Not entirely sure the issue here.

Should be obvious when you go to

Send some screenshots if you are still experiencing issues

See here

Hi Sam,

Has your site been hijacked or something … when I go to … I immediately get the following. In fact, even saved urls to some area of your site re-direct to the same “ACCEPT new poicy changes” which re-direct to “” with really bad terms - to me as a subscription holder - compared to what I have experience in the past …

Thanks for the screenshots.

Will have my team look into this asap


Teachable is the host of our portal platform. But this is still odd to be seeing this in my opinion.

We are looking into it.

Thank you Sam! FYI, IF I just visit your site, I get no such obstacle … it is ONLY when I try to log-in as a “paid member/subscriber”. I tried several times over the last several days, ech time thinking that this was simply a temporary issue. It went away at one time, but I didn;t have time to spend and whan I cam back yesterday, it was back and basically, until and unless I agree to this “New Policy” - expecially the TOS … I can NOT log-in.

@SiliconValley, we tried to replicate the issue on our end but we’re not encountering the same problem you raised. We’re wondering if this has something to do with cache. In case you haven’t yet, can you please try to clear your cache then try logging in on another browser.

Sorry, I got tied up … THIS is a completely separate laptop and SAME challenge log-in and under ACCEPT new TOS.

Guys, this is a BRAND NEW laptop as 25 days ago, I had my laptop screen fail and did not follow-up on this thread. So, needless to say, I am quite frustrated that TODAY - 25 days later - as I clicked on “Ask Sam Anything email” … I once again GOT the SAME TOS screen when I clicked on “Training Log-In”.

So, it just can’t be a calear cache issue and I am using Chrome … WHY can’t I log-in and access MY EXISTING MEMBERSHIP???

Come on … Isn’t there a way to go DIRECTLY IN to my existing membership???