Latest Enterprise DNA Initiatives

Unable to download PBIX file from Power BI service

Hi Everyone,

My client has given me access to workspaces as a member and i am unable to export the PBIX file from the workspace for all reports. I have checked their side and they are able to do this with the drop down being present.

Below is a screen shot showing the option is not even present. Is anyone able to kindly advise what setting i need to enable? Thanks in advance all…

image

@Hitman,

Check out the article below. There are a lot of subtle limitations that will prevent the download of the PBIX file.

https://docs.microsoft.com/en-us/power-bi/create-reports/service-export-to-pbix#considerations-and-troubleshootinghttps://docs.microsoft.com/en-us/power-bi/create-reports/service-export-to-pbix#considerations-and-troubleshooting

There are a few important considerations and limitations associated with downloading a .pbix file from the Power BI service.

  • To download the file, you must have edit access to the report.
  • The report must have been created by using Power BI Desktop and published to the Power BI service, or the .pbix file must have been uploaded to the Power BI service.
  • Reports must be published or updated after November 23, 2016. Reports published earlier aren’t downloadable.
  • This feature won’t work with reports and content packs originally created in the Power BI service.
  • Always use the latest version of Power BI Desktop when you open downloaded files. Downloaded .pbix files might not open in non-current versions of Power BI Desktop. For example, you cannot open downloaded .pbix files using a Desktop version that does not support information protection.
  • If your administrator has turned off the ability to download data, this feature won’t be visible in the Power BI service.
  • Datasets with incremental refresh can’t be downloaded to a .pbix file.
  • Datasets enabled for large models can’t be downloaded to a .pbix file.
  • Datasets modified by using the XMLA endpoint can’t be downloaded to a .pbix file.
  • If you create a Power BI report based on a dataset in one workspace and publish to a different workspace, you and your users won’t be able to download it. The download feature is currently not supported in this scenario.

I hope this is helpful.

– Brian

1 Like

Hi Brian,

Hope you are well. I had checked these before but maybe i’ve misunderstood a couple

I think it must be either that i do not have access or the administrator has turned off ability to download (they are still able to download it sounds like the first option). Any tips where to look for these?

Hi- I think i have found the problem. Thanks Brian

image

@Hitman,

Yup, looks right. I was just checking to see as a Member how much visibility you have into the Administrator Settings. Answer is “not much”, so I think you’ll need to confirm your hypothesis with the Workspace Administrator.

  • Brian

P.S. Man, time flies. I saw the message that this was your first post in 7 months! Hope you’re doing well also.

1 Like

Hi @Hitman, did the response provided by @BrainJ help you solve your query? If not, how far did you get and what kind of help you need further? If yes, kindly mark as solution the answer that solved your query.

I also hope that you are having a great experience using the Support Forum so far. We’ve recently launched the Enterprise DNA Forum User Experience Survey, please feel free to answer it and give your insights on how we can further improve the Support forum. Thanks!

Hi @Hitman, we’ve noticed that no response has been received from you since the 17th of May.

We just want to check if you still need further help with this post?

In case there won’t be any activity on it in the next few days, we’ll be tagging this post as Solved.

Hi @Hitman, due to inactivity, a response on this post has been tagged as “Solution”. If you have a follow question or concern related to this topic, please remove the Solution tag first by clicking the three dots beside Reply and then untick the check box.

We’ve recently launched the Enterprise DNA Forum User Experience Survey, please feel free to answer it and give your insights on how we can further improve the Support forum. Thanks!