Text field truncating in export to csv

Hi All,
I am exporting my table and for some reason, my Product Code column is changing the format in csv to be 3.XXXX+e11 rather than the Product code.
Images attached showing table in PowerBI and csv format


Hi @KiwiNigel,

Looks like in Excel the cell formatting is “General” not Text. Think you are just opening the CSV with Excel. Instead you could use the import from CSV to enforce Product Code as text or…

Use VBA, copy this script into a new Module.
Select a range on your worksheet, press ALT+F8 : Run the macro

Sub ValuesToText()

Application.ScreenUpdating = False

Dim C As Range, T As String
    On Error Resume Next
    For Each C In Selection
        T = ActiveCell.Value
        C.NumberFormat = "@"
        C.Value = CStr(T)
    If IsEmpty(C) Then
    End If
On Error GoTo 0
    ActiveCell.Offset(1, 0).Select

End Sub

I hope this is helpful

1 Like

Hi @KiwiNigel, did the response provided by @Melissa help in solving your query? If not, how far did you get and what kind of help you need further? If yes, kindly mark as solution the answer that solved your query.

Hi @KiwiNigel, due to inactivity, a response on this post has been tagged as “Solution”. If you have a follow question or concern related to this topic, please remove the Solution tag first by clicking the three dots beside Reply and then untick the check box.