Table Not showing all records when exporting

Hey Guys,

Just have a rather simple question with a problem I am having. I have a table in Power bi which has 10,100 records but for some reason when you use a table visual and try to export the data it reduces the number of records, does anybody know the reason why?

I have also tried to import different tables and its the same problem when exporting the recommendation I got was to click on show items with no data but still not seeing all the records when the data is exported. Images Below:

Hi @Stefan

I believe there is a limit on exporting data from a table visual (even if you export as csv). I had similar problem. Although I wouldn’t advice exporting a table, you can do this by selecting the table itself in the table section and select copy table. Paste this in an excel.

Cheers

Please see this article on exporting data from a visualization
this link wil direct you to the section on considerations and limitations, scoll up for more details.

1 Like

Copy the entire table in the Data section I meant…

Hi @Stefan

Just go in your data view and right click on your column and copy table.
It will copy all the records for you.

Thanks
Ankit

Thanks, Guys. Especially for the link @Melissa, I read through it and it said when exporting CSV files it has a 30,000 limit which is not in my case right here so I guess I am still confused honestly.

The suggestion which you guys suggested to copy the table and paste it in excel is great but I already knew about that option. The problem I am having is that this was just a test before I build out the actual report I was asked to. ( So I setted up the connection with the SQL server import data option with a simple table and published the report and when am now trying to exporting it I am not getting back all the records for some reason)

Normally I would have the pull data from the database and give various team members, so the idea was to build a dashboard report with the table and set up the SQL Server connection and set a schedule and they would just export the data themselves on the Report Server. This would save me from pulling the data every time and updating the excel sheet in the folder we have.

Thanks again. Any suggestions would be great.

Hi @Stefan,

As an alternative have you considered using the “Analyse in Excel” option?

Thanks for the suggestion @Melissa. Went through it but not exactly what i was looking for. Do you have any ideas though why wouldn’t it be showing all the records since the documentation said 30,000?

What report export option is selected?
Is that: “Allow end users to export summarized data from the Power BI service or Power BI Report Server”
.

I don’t know what you’ve tried thus far but instead of CSV can you select export to XLSX??

Hey Melissa,

It’s the PowerBi Desktop so the only option I see when I click on export data is that it saves it as a CSV file.

Really not sure why I am getting the issue but I am just gonna move on.

@Stefan there is one last test you can perform I think and that’s adding an Index column to your table in Power Query (don’t know if your serial numbers are unique?). Then add this index to the table visual and test the export to CSV one last time…
You’ll be able to identify pretty quickly which records didn’t export.

Hi @Stefan , we’ve noticed that no response has been received from you since the 26th of March. We just want to check if you still need further help with this post? In case there won’t be any activity on it in the next few days, we’ll be tagging this post as Solved. If you have a follow question or concern related to this topic, please remove the Solution tag first by clicking the three dots beside Reply and then untick the checkbox. Thanks!