New Enterprise DNA Initiatives

Subtotal is now ok, but Grandtotal is still wrong, but not in waterfall chart

Hi!

I’ve got problem with my grandtotal results. Earlier I had problems also with subtotals but now subtotals are ok.

Very weird thing for me is that grandtotal value is correct ONLY when I use waterfall chart, in any other visual the result is 824 889 which is wrong.

Why this is happening? Why dax is not suming all of values like it did in subtotal?

Here are my results:

And here is my measure:

I suspect the context would be the answer to my question, but I thought I solved the problem using SUMMARIZE.

Hi @wojteq , we aim to consistently improve the topics being posted on the forum to help you in getting a strong solution faster. While waiting for a response, here are some tips so you can get the most out of the forum and other Enterprise DNA resources.

  • Use the forum search to discover if your query has been asked before by another member.
  • When posting a topic with formula make sure that it is correctly formatted to preformatted text </>.

image

  • Use the proper category that best describes your topic
  • Provide as much context to a question as possible.
  • Include the masked demo pbix file, images of the entire scenario you are dealing with, screenshot of the data model, details of how you want to visualize a result, and any other supporting links and details.

I also suggest that you check the forum guideline How To Use The Enterprise DNA Support Forum. Not adhering to it may sometimes cause delay in getting an answer.

Please also check the How To Mask Sensitive Data thread for some tips on how to mask your pbix file.

One more. Subtotals were wrong, but when I used summarize and sumx they are now ok. I thought that grandtotal in this case will work properly too because I write in my measure that when is there is more then one value of “Trasa 2” (it is second level value in rows) it should use SUMX. But for some reason it dosen’t work in grandtotal like in subtotal. Why is that? And why there is correct result ONLY in waterfall chart?! :open_mouth:

Hello @wojteq , due to the length by which this post has been active, we are tagging it as Solved. For further questions related to this post, please make a new thread. When starting a new post, I suggest linking this thread, provide as much context to a question as possible and include the masked demo pbix file, images of the entire scenario you are dealing with, screenshot of the data model, details of how you want to visualize a result, and any other supporting links and details. Thanks!

Anyone can help? :slight_smile:

Hi @wojteq - Yes, DAX is all about Contexts. In your case if you are having both Rows and Columns in Matrix, then for Grand Total you will need to consider both Rows and Columns context.

As while calculating Grand Total, DAX will consider all values for Rows and Columns as there is no Filter for any while Calculating Sub-Total DAX will consider all value only for Rows if Calculating for Column and all values for Columns while calculating for Rows Subtotal.

Hope this is somewhat clear. For complete solution, Request you to share PBIX file for us to help further.

Thanks
Ankit J

1 Like

Hi @wojteq , did the response provided by @ankit help you solve your query? If not, how far did you get and what kind of help you need further? If yes, kindly mark the thread as solved. Thanks

Hi @wojteq, we’ve noticed that no response has been received from you since the 23rd of December. We just want to check if you still need further help with this post? In case there won’t be any activity on it in the next few days, we’ll be tagging this post as Solved. If you have a follow question or concern related to this topic, please remove the Solution tag first by clicking the three dots beside Reply and then untick the checkbox. Thanks!

A response on this post has been tagged as “Solution”. If you have a follow question or concern related to this topic, please remove the Solution tag first by clicking the three dots beside Reply and then untick the check box. Thanks!