Relationship tables are grayed out

Hi, I am attempting to edit my relationships and structure my model but when I go to the relationship view everything is grayed out and don’t even shown any existing connections either (which I know there are some). I have included a screenshot of what I am seeing. I have tried the basics of saving/closing/re-opening the report. I have tried refreshing the datasets. I have tried reconnecting the data source, but nothing seems to have worked. All of the data is coming from dataflows in PBI service. Any ideas would be appreciated, thank you!

Hi @bbarth, have you also tried copying and pasting all the data queries into new powerbi desktop file?.

I’ve been having this same problem since the March update - my solution was to roll back to February’s version of desktop. It’s very frustrating, I haven’t gotten any answer from support on it either.

Microsoft have released a mini update to March 20 update on the 1st April, updating the version to 2.79.5774.0. Would be interested if this new version has resolved this issue…

No, but that’s only because I have spent a ton of time formatting and doing a lot of work that I really don’t want to start from scratch. It was working just fine and then suddenly grayed out.

I can’t find a newer version. I did install the latest version this morning (2.79.5768.1082), but I can’t find the version you are referencing.

I had been on the February update when the issue emerged so I installed the latest version hoping for a fix, but it had the same issue.

Is your connections Direct Query or Import?

@marcster_uk I can’t seem to get that update version - I’m still on 2.79.5768.1082 for March…
and now I have to go back and re-download the February version, because I over-wrote that in trying to test.

@bbarth here is the link to the prior month versions of Desktop if you need to try rolling back:

All of my data comes from Power BI Dataflows which would be the Import method.

Thank you. I will give that a try.

I rolled back, but now I get this error when attempting to open my pbix file.

something went wrong

I can think of a couple of possibilities -

  1. you have the option for 64 or 32 bit when downloading, did you select the proper version?
  2. is there any chance you used the new COALESCE function in your model? That wouldn’t be supported in the February version.

I double checked and it was the 64 bit version and no I haven’t used the COALESCE function.

since the model was working in the newer version, you can try reloading that to see if it helps.
when I rolled back to February, the error message I kept getting was that my model had been authored in a newer version of PowerBI Desktop, I just clicked OK and it went ahead and loaded the model.

I keep hoping they will fix the greyed out relationship problem with the next update to desktop

Hi @bbarth, A response on this post has been tagged as “Solution”. If you have a follow question or concern related to this topic, please remove the Solution tag first by clicking the three dots beside Reply and then untick the check box. Thanks!

@bbarth - I finally found a real solution to this problem, led to it by a post on the PowerBI support forums.

Apparently, some change has been made and certain symbols are not completely acceptable in the latest PowerBI table and even column names.

The poster I read solved his issue by removing commas from his table names. I had a few tables that included underscores in their names, and I removed those. This did not fix the problem, so I went back and removed a few dashes from table names, also not a fix. Finally I removed any and all symbols from my column names - and this was the final fix.

I can once again see the table relationships in the model view.

I don’t know if there was just one symbol that was the problem, or if I did need to remove all of the dashes from the column names.
Symbols removed from table names were _ and - (some were loaded to the data model, others were not)
Symbols removed from column names were ( ) $ - and :