Refresh Problems - but Query Editor looks OK

I’m trying to move a data model from Excel to Power BI.

I moved around some of the source files that feed in data for the tables.

The queries look fine in the Query Editor and I can Refresh Preview without problem.

but when I go to the report page and click Refresh I get the following message:

Does anyone know why this is happening? I’m just starting out, but I’m afraid of doing a bunch of work and then discovering the model will never be able to refresh.

The only special clue I can offer is that when I first open the query editor, some of the queries like GL Data start out with an ! image
But after a while they seem to clear themselves up.

Hello @BillK,

Thank you for posting your query onto the Forum.

Since you’ve moved around your files or have changed the location of the file path, have you considered changing your file path under the change Data Source settings from the Query Editor? And this might be reason why it showed you a “Warning” sign at the opening of the Editor because the data might not have been loaded properly in it.

When you change your data source, sometimes file may not get loaded properly in the Query Editor and then when you refresh the data it will produce a conflict message.

Try changing the file path of those files that you’ve moved under the Data Source settings in the Query Editor.

Hoping this helps you to restore and load your files and gets your data refreshed. :slightly_smiling_face:

Thanks & Warm Regards,

I just did a little experimentation. I made some changes to the raw data that is being imported. I can see the changes captured in the Query Editor. I can also see the changes captured in the data view.

But in report view the new data doesn’t seem to be flowing through. I do a visual and it doesn’t reflect the new data.

I went into the Data source settings. Most of the new locations are listed. I can also see a reference to the old location. (I’m not sure if there is a query still referring to it or not)

The Change Source… button at the bottom is greyed out. The only options available to me are Edit Permissions… and Clear Permissions

Any suggestions on what to do next?

Hello @BillK,

Since the Change Source button is grayed out and the old location reference is still visible it implies that the report that you’re looking at is still referencing the data from the previous data model. You need to go back to the original data model or report and add your tables back there.

Thanks & Warm Regards,