"Pending Changes" Warning Won't Go Away

I have a PBIX file that I have been working on for several months, with no issues. Yesterday, I made several changes to it throughout the day, and it was working fine. At some point in the afternoon, it started telling me that I had pending changes that still hadn’t been applied.

From that point on, no matter what I have done, that message won’t go away. If I click “Apply changes,” it acts like it’s applying some metadata changes, but the warning that I have pending changes still remains.

Applying Changes

If I click “Discard changes,” I get the following message. Click “Discard” just dismisses the message, but the pending changes warning still remains.

Discard Changes

Even if I go into PowerQuery and make other changes to my data, when I apply those changes, they all apply, but the warning remains and behaves the same as described above. I tried doing a “Save As” to save to a new file, and that doesn’t change anything either.

I can publish the report, and it seems to work fine, but, not only is this message extremely annoying, I worry about it being a precursor to other things going wrong with the file.

Any ideas on how to fix this? I know the first request is going to be to share the PBIX file. Unfortunately, I can’t do that due to the sensitivity of the data. Sorry…

@DaveC,

I’ve run into this issue myself, and you’re probably not going to be entirely satisfied with the answer. Power BI unfortunately does not have the ability to rollback to the previous version, so the best you can do is try to delete the steps you added yesterday, and incrementally add them back, to try to isolate which one caused the problem.

The ability to discard query changes to clear this “pending” message is one of the ideas up for vote on the Microsoft forum, currently garnering a lot of support with over 400 votes

Here’s a relevant thread on the Microsoft community that you may find informative:

Wish I had a better solution for you.

  • Brian

@BrianJ, you’re right–that’s not a very satisfying answer! But thanks for letting me know what I was up against. After reading your reply, I was a disappointed because this is not a new report I’m building. Rather, I’m updating and improving an existing report. That meant that the things I have changed recently have not been brand new steps I could simply go back and remove. The changes were scattered all through the model at various steps in several different queries. But…

After going back and reviewing the details of the situation, it seemed that the issue had something to do with my “DataStartDate” parameter that it kept referencing when I clicked “Discard changes” button. So, I went into PowerQuery, changed the three places where I was referencing that parameter to hard-coded date values, and deleted the parameter from the model. I then closed PowerQuery and applied the changes. Voila! That fixed the problem! I then went back into PowerQuery and recreated the parameter, and still no problem!

So, I think I’m back in business! Thanks for your help! It got me to look at the problem a little differently, and helped me find the solution.

1 Like

One thing that I have found helpful is to save all my files to onedrive, which then gives me th option to open different versions.

1 Like

Great suggestion! I’ll have to look into that…