Need help how to display Measure column header as Date

Designing report for a client with rolling 14 days. I am using a measure to help calculate the rolling dates. I have the data doing what I want but I need to display the column header on the measure to be the actual date it is representing. Currently, I have the measures named “14DaysAgo”, “13DaysAgo” etc. and that is what is displaying in the column headers. How can I change this header to show the actual date ex. 08/19/2020, 08/20/2020 etc.

What is the definition of 14DaysAgo, is it from today or some other day, is it static or dynamic?

As far as I know we can not do because Measure name is basically a key. But you can work around by creating custom titles and placing above the headers for each of our required header( you need to fix the size of the table so that your dynamic visual card should not shift).

Below document may give you how to do dynamic title.

Agreed … AFAIK this is not a “feature” of Power BI Desktop yet … the custom title approach is a workaround.

Hi @Preston

One way is create cards with dates and place on top of headings.

If possible please share you pbix file with sample data.

Hi @Preston , did the response provided by the other members help you solve your query? If not, how far did you get and what kind of help you need further? If yes, kindly mark the thread as solved. Thanks!

Hi @Preston, we’ve noticed that no response has been received from you since the day of posting on the 3rd of Sept. We just want to check if you still need further help with this post? In case there won’t be any activity on it in the next few days, we’ll be tagging this post as Solved. If you have a follow question or concern related to this topic, please remove the Solution tag first by clicking the three dots beside Reply and then untick the checkbox. Thanks!

Hi @Preston,

This article may provide a solution to your problem. Looks like quite a neat way to tackle it.


Thank you everyone for your help. I was able to add measures displaying dates and placed them in the proper location which gave me what I needed. Sorry for the delay.