Measure Table Refresh Error


Just tried refreshing a model and it failed on a Measure “Table”.

The table contains only measures (with the correct calculator icon) and the error i receive is:

“Expression.Error: We cannot convert the value “” to type Table.

When i delete this step it converts the table to a table icon and inserts a blank table. Ive looked at the advanced editor and wasn’t able to fix

Any idea what i’ve done wrong guys?


Here’s the M code for a standard Measure table created via Enter Data:

Source = Table.FromRows(Json.Document(Binary.Decompress(Binary.FromText(“i44FAA==”, BinaryEncoding.Base64), Compression.Deflate)), let _t = ((type nullable text) meta [Serialized.Text = true]) in type table [Column1 = _t]),
#“Changed Type” = Table.TransformColumnTypes(Source,{{“Column1”, type text}})
#“Changed Type”

Can you please take a look and see where your code differs? That may help diagnose what’s going on.


  • Brian

This was a strange one. The M code was blank. I tried recreating M code but was quicker to delete the measure table and create again and it refreshes fine now after i deleted the old one. Not sure how that happened but at least its all good now. Cheers for quick response

Hi @Hitman / @BrianJ. I’ve been seeing this Measure Table Refresh error a few times recently as well … I’m beginning to think it may be an issue with the latest Power BI Desktop versions (May 2020? as well as June 2020) as I don’t recall it being an issue historically. I’ve begun to save a backup copy of my PBIX before I make any changes to my data model just in case. Greg

@Hitman and @Greg,

I have no idea whether this is related to your problems above or not, but another recent quirk I’ve found related to Measure tables is with regard to the Column 1 that is automatically created when you create your Measure table via Enter Data. My practice in the past has always been to delete that Column 1 as soon as I entered my first measure in the table.

However, what I’ve recently learned is that by doing so you make the Measure table unreadable by some third-party products, including Monkey Tools. So now, to keep that from happening I just hide the Column 1 column in report view, rather than deleting it.

Most likely not the cause of your problem, but worth mentioning I thought.

  • Brian

Thanks Brian - I always delete it too and did that the second time round. If you hide it do you still get the measure icon?


> If you hide it do you still get the measure icon?

Yes, you still get the measure icon and the table still rises to the top of the field list. As far as I can tell, it still behaves exactly as it does when you delete the column, but just keeps the table readable by other programs.

– Brian

I always have deleted it too … AFAIK there’s no difference to the user experience between hiding and deleting “Column 1”… I’ll begin hiding it and see if that help. Thanks guys.