Financial Reporting Template Formatting

Hello,
I watched the Financial Reporting Template course and am having a formatting issue. In the course the template totals are indented. I followed the same process and have indented my totals, but the indentation is not retained once I add the Items field to the table. Is there a formatting option that I need to adjust to get this to work? I’m attaching screenshots of my table and the visualization.


Yes this is an easy fix, and I think a recent change to some Power BI settings has caused this.

I explain this during the course content, but all you need to do is make sure there is no ‘word wrap’ in the values or column area.

You can fix both these in the formatting section of the table visual.

See how you go with this.

I do go over this a couple of times within the course videos.

Sam

Thanks! That was my indeed the issue. I appreciate the quick response.

Hi Sam,

I am having this same issue and I have turned off the word wrap (Column Headers and Values), it still doesn’t work. Please what can I do.

image

This my template:

Thanks.

Can you look to turn off wordwrap for rows as well, and for general values to. This really is the only way it could be happening.

Also just make sure you’re pulling in the right column but I’m sure you are just a heads up.

Sam

Still no luck after this add a demo model of what you’ve got and we can have a look through

Hi Sam,

I finally fixed it. I had to open one of your templates to understand what went wrong. The problem was I was using indentation instead of actual spaces.
Thanks.

Hi @Phaniey, so you are importing an excel spreadsheet is that right? And you made the gap with indents (tab) as opposed to pressing space bar.

Btw, I just paste templates directly into Power BI table to avoid the excel import routine altogether. I think I may have had the same issue as I pasted the indented content from Excel initially too.

Oh right. Thanks for sharing. Makes sense.

Sam

Hi

Also trying to indent line items in a table. So initially used “tab” function in excel to indent the descriptions, however, didn’t pull through formatting to Power BI.
Then tried the “spacing” option in excel as mentioned above - this worked with showing the indentation in Power BI, however, my current formulae fail to pick-up the data links to the descriptions due to the spacing.
How can I rectify this?

Have you tried to remove the spaces within your formula logic by wrapping TRIM around it?

https://docs.microsoft.com/nl-nl/dax/trim-function-dax

1 Like

Hi @Stuart, we’ve noticed that you posted on an inactive and previously tagged solved topic. For more visibility please start a new topic within the forum. You may check this how-to guide for reference - How To Use The Enterprise DNA Support Forum How To Use The Enterprise DNA Support Forum