Latest Enterprise DNA Initiatives

Excel Data upload

Hi Guys,
I am stuck with error message Expression.Error: The key didn’t match any rows in the table. when refreshing the data.
Capture
I have tried to re-create the excel removing the table formant and refreshing but unable to resolve the issue.
Appreciate your feedback in understanding the problem and resolving.
Thanks,
Siddharth

Hi @Siddharth,

This error appears when you rename one of the source properties either Sheet or Table name.
Here’s an article on the issue.

I hope this is helpful.

1 Like

@Siddharth

Here its expecting Table
Item = Table Name(Temp_Gain) Kind = Table

If you remove Table format pass sheet name to Item and Kind = Sheet
Item = Sheet Name, Kind = Sheet

1 Like

Great advice from Melissa and Rajesh.
As to how I would solve this myself: I would go into the Advanced editor of the query editor and take a copy of the code. Afterwards I would delete line by line to see which line gives me the issue. I would then change this line and combine this with the old file.

@Melissa - thanks for the sharing the blog, it is very insightful and I understood my mistake and will be very helpful in future.
Thanks once again.
Regards,
Siddharth

1 Like

@Rajesh - when I removed the table format, the table “Temp_Gain” was lost. Done as directed and problem solved.
Thanks
Siddharth