Error Messages - When Refreshing

My data model imports 2 Excel Spreadsheets and there are a small amount of measures. Never had an issue until the other day. Receiving the error message posited.

image

Hi @mbraun, we aim to consistently improve the topics being posted on the forum to help you in getting a strong solution faster. While waiting for a response, here are some tips so you can get the most out of the forum and other Enterprise DNA resources.

  • Use the forum search to discover if your query has been asked before by another member.

  • When posting a topic with formula make sure that it is correctly formatted to preformated text </>.

  • Use the proper category that best describes your topic

  • Provide as much context to a question as possible.

  • Include demo pbix file, images of the entire scenario you are dealing with, screenshot of the data model, details of how you want to visualize a result, and any other supporting links and details.

I also suggest that you check the forum guideline How To Use The Enterprise DNA Support Forum. Not adhering to it may sometimes cause delay in getting an answer.

1 Like

Here are a couple of suggestions:

try to go into the data tab and refresh one table at at time. this will help you narrow down on the table that is causing the issue.

image

once you have the table defined check if you deleted or renamed any measure

if that also does not fix your problem create a new table, moving the measures to the new table and later remove the older table. rename the new table to reflect the older table name.

let me know if this fixes your issue.

1 Like

Hi @mbraun

Check below post. These have additional methods to identify and reasons that may be causing this problem.

Thanks
Ankit J

@mbraun, I ran into the same issue on many of my models. In some cases my models would not even open let alone refresh. In all cases that I ran into this problem it was tied to the tables that I created to hold my various measure calculations. The work around that ended up working for me was to open up the Power Query Editor, find the applicable measure table, and then delete the last applied step which was a “Removed Column”. Once I did this and applied I was able to refresh without an issue.
Hope this helps in your case.

Hi @mbraun, we’ve noticed that no response has been received from you since the 7th of May. We just want to check if you still need further help with this post? In case there won’t be any activity on it in the next few days, we’ll be tagging this post as Solved. If you have a follow question or concern related to this topic, please remove the Solution tag first by clicking the three dots beside Reply and then untick the checkbox. Thanks!

Good day @mbraun,

This refresh error is due to your measure table, which is “Key Measures - Refunds” in your model.
Solution: Create a new measure table and move all your measures to the new one and later remove the old.

I really hope this works for you as it did for me :smiley: