Directquery against PBI Dataset


Power BI newbie here. I’ve created a PBI dataset and published it to the service. I have then created a new dashboard off of the PBI dataset. I have made changes to the original PBI dataset, even after refreshing the dataset in the service, when I open the dashboard using the dataset, it doesn’t reflect my changes.

If I reimport the dataset, then it does. However any new columns added are lost. Is there anyway to refresh the dataset without losing columns added and not having to re-add the dataset everytime. As this causes much rework.

Thanks for your help.

Bumping this post for more visibility from our experts and users.

@d.chek When you say you have made changes to original PBI dataset, what exactly did you do? re-publish PBIX or just changed model’s metadata using TE3 or ALM Toolkit?

I changed the PBI dataset, added a column. Then i republished the dataset and the change wasn’t reflected in my PBI dashboard that references the dataset.

I since have discovered that I’m using the PBI desktop from the Microsoft Download center, because I need to apply some ODAC settings for connecting to Oracle.

If I use the PBI Desktop from the Microsoft store then everything works as expected. However, I can’t use the Microsoft Store version to connect to Oracle. I really don’t want to have to use two versions. Then it won’t work if I ever need to combine data from Oracle and a non-oracle database.

Hope this helps.

@d.chek There shouldn’t be any difference, when you re-publish you destroy the existing instance of the dataset & report and re-create a new one, so if you can view the columns in PBI Desktop then it should be visible in PBI Service as well.

Extract model.bim from PBI Service and PBI Desktop using Tabular Editor and use any online JSON comparer to check if there is even any difference.

Remember for the dataset it is a direct query in the new report. So I publish the dataset to the service. The existing report using that dataset should already have the new dataset since it is a direct query. The changes to the dataset are there. But they are not reflected in another PBI report that is using that dataset, even though it is a direct query. Does that make sense?

Bumping this post for more visibility from our experts and users.

Hi @d.chek - ideally there shall not be an issue as once you have Republished the dataset the changes shall reflect in the Dashboard using PBI dataset also irrespective of if Power BI in installed from store or site.

Can you try using Refresh in the new Dashboard and see if changes are visibile. Also check on suggestion given by Antriksh.

Ankit J

Thanks Ankit for the response. So I believe the problem is not in the service, but in the desktop versions when I make a change to the dataset, republish, the change is not reflective in the desktop version from the download site, but it reflected in the change from the desktop service from the store, even after refreshing in the desktop. I can try and extract the model as Antriksh, if you can provide me some instructions on how to do that, sorry I’m pretty new at this.


@d.chek download and install and then connect to PBI Desktop and Service and ALM Toolkit will compare both and highlight differences.

1 Like

@AntrikshSharma I’m downloading now. Put the problems appear to be between versions on Power BI Desktop versions. What I’m finding, is I made changes to include a new column in the DirectQuery of the PBI dataset. This created a local dataset copy, thus appears that I know have to refresh my PBI dataset original and the dataset running off the PBI dataset original, because I added a column. It seems I can add measures that won’t require a local copy of the PBI dataset, but not new columns that would be relevant in just a single report.

Hi @d.chek,

Please let us know if the suggestion from @AntrikshSharma (thank you) has helped you solve your inquiry.

If it does, kindly mark the answer as the Solution.

Thank you!

Hello @d.chek,

Just following up if the response above help you solve your inquiry.
If it did, please mark his answer as the SOLUTION.

We’ve noticed that no response was received from you on the post above. In case there won’t be any activity on it in the next few days, we’ll be tagging this post as Solved.

@d.chek -
I have just run across what I believe to be the same problem in my system.

I have a large dataset that runs multiple reports - I added several measures (and a column) in this dataset to be used in an existing report that I was updating.

I uploaded the updated dataset, and started editing the slim report (the one connected to the dataset) once the refresh of the dataset file was complete.

I then uploaded the slim report and got errors on the new measures - saying they did not exist in the file.

I opened the edit option in the service for that report and clicked the refresh button then saved it and returned to reading view - that fixed the problem.

I think MS has changed something (which may change back) - because this was NOT an issue with previous changes to my dataset.

Hi @d.chek,

@Heather has shared the same experience as what you are facing right now. Can you give her solution a try and let us know if it solved your problem?

In case there won’t be any activity on it in the next few days, we’ll be tagging this post as Solved with Heather’s reply as the solution.

Thank you!

Hi @d.chek

Due to inactivity, a response on this post has been tagged as “Solution”.

If you have a follow question or concern related to this topic, please remove the Solution tag first by clicking the three dots beside Reply and then untick the check box.

We request you to kindly take time to answer the Enterprise DNA Forum User Experience Survey,.

We hope you’ll give your insights on how we can further improve the Support forum. Thanks!


Sorry for the delayed response, I’ve been on vacation. Your suggestion worked perfectly, definitely seems like a bug in Microsoft. Thanks so much your are a life saver.

1 Like

Hi Jean Rose,

Sorry for the delayed response, I’ve been on vacation. Heathers suggestion resolved the issue. Thanks