Date Slicer first need to show date,month & Year

I have created a date slicer, date i have taken from dates table. In slicer it shows month,date & year but I want first date,month & year. please let me know how to fix it?
dates table I am using same as Sam McKay used in training.


Is that also how the Date column value is displayed in the Date Table?
if so go to Table view, Column tools - select the Date column and change the Format on the ribbon.


In Model view it’s even possible to enter a customized field formatting…
I hope this is helpful.

I did the same. Still slicer is showing same month,date and year.

Can you provide a sample file OR some screenshots?
I’d like to see at least the Dates table AND the Fields section for your Slicer - thanks.

Dates Sample.pbix (75.9 KB)

Attached please find a sample file. I need first date , month & year.

Thanks & Regards,

Well do you believe it, when I open the file, the Slicer shows day-month-year…

So can you check and maybe change the Regional Settings? I hope that will fix it for you.

But here is not working even I selected English (United States) in Regional settings.

I apologize. I didn’t mean for you to switch to US just check if that setting is in line with your region.
But I do believe I have the solution, check your system settings - think that might be the cause…


Thanks a lot Melissa. I have done now, It’s in Region setting in system setting.

I think if your regional settings are set to your current region, it should be able to fix this.