Date hierarchy options are missing

Today after I added my date table I noticed that I no longer have the option of picking the hierarcy as Sam has demonstrated in several of the training videos. I have been able to see it and use in until today. Not sure what changed. Attached is just a simple PowerBI file and a screenshot!

The first shows what I am used to seeing.
DateHierarchyYes !

Now what I get when I click on the down arrow is a dialog box.

DateHierarchyNo !

I don’t know if I am missing something or if something has changed.

Corporate ScoreCard.pbix (1.4 MB)


That is strange. I don’t see it there either, but it just takes a few seconds to re-create via drag-and-drop in the Fields pane.

— Brian

Thanks Brian,
Didn’t occur to me that I could drag and drop to build the Hierarchy.


Yup, I learned that trick because I’m always accidentally dragging fields on top of each other and creating nonsense hierarchies that I then have to delete… :crazy_face:

  • Brian
1 Like

Too Funny, I totally get it. :grinning:

@lol I learned the same way…I kept creating hierarchies over and over again


Where’s Clippy when we really need him?

  • Brian



He didn’t get promoted to Power Bi :smile:

1 Like

Clippy is funny. I also did a little bit more digging and found out that the issue was I turned off the Time Intelligence Auto date/time for new files setting. I turned it back on and created a new file and the Hierarchy retuned as I saw it before. So that explains the mystery. The real question is the value of turning it back on and off. Here is a link to the Microsoft article.


You are much better off turning off the auto date/time option and marking your date/calendar table as a date table. As soon as I’m back at my computer I’ll send you a link that does a great job explaining why.

  • Brian

Awesome, Thanks Brian.


Here are three very short videos (about 13 min total) that do a brilliant job explaining the Mark as Date Table option, and why to turn the auto date/time feature off.

  • Brian