Latest Enterprise DNA Initiatives


Custom Columns not showing in Report view

hello -
I created a custom column in query editor and applied it to the data set. When i am in report view, the column isn’t showing the data. However, there is data in the drop down filter when I clink on it. And it isn’t just happening with the custom column. Another one of the columns has data from the original source and there are no values in the column in PBI. However, if I use the drop down filter for that column, the data is in the filter. Pictures Attached. I have checked relationships in the model to ensure they are correct. Does anyone have any other suggestions for troubleshooting?

@LisaSessions,

Welcome to the forum – great to have you here!

Have you checked the filter pane to make sure you don’t have a stray filter condition set that is keeping the data from displaying in report view?

Another technique I use is the DUMPFILTERS measure technique to diagnose the full filter context that may be affecting that data in the report view. Here’s a good article on how to apply that approach if you’re not familiar with it:

If neither of those work, I would suggest posting a masked version of your PBIX file on the forum, so we can better diagnose your problem. Here’s a brief video on techniques for masking sensitive data in your file:

I hope this is helpful.

– Brian

1 Like

@LisaSessions

This happens when the data is not properly loading into data model.

Copy the M code and delete the table from Query and re create table again…

1 Like

Thank you!

Thank you for all the information

I have also faced this strange sometime back.
Things you can try,

  • Restart the Power BI Desktop
  • Install latest Power BI Desktop

Hi LisaSessions, did the response provided by the users and experts help you solve your query? If not, how far did you get and what kind of help you need further? If yes, kindly mark the thread as solved. Thanks!

Hi LisaSessions, we’ve noticed that no response has been received from you since the 24th of January. We just want to check if you still need further help with this post? In case there won’t be any activity on it in the next few days, we’ll be tagging this post as Solved. If you have a follow question or concern related to this topic, please remove the Solution tag first by clicking the three dots beside Reply and then untick the checkbox. Thanks!