Changes Using Advanced Editor


#1

I was working on my first model and found out I brought in the wrong column for sales data. There were two and I deleted the second one.

I tried to delete the removal of Inv. Price in the editor by removing the row, but that gave me another error.

Can you help to fix? Will the deleted column appear in the query after the change or refresh? Thanks.

Applied%20Steps


#2

Hard one to know without actually testing it and seeing if I think.

But the great thing about the query editor is you can just play around and you won’t break anything. Have you tried a few things to see if they fix it?

Did you jump back into a previous transformation and attempt to change it?

This is a pure guess but you see below

The type is different, so it may not be finding the correct column? I’m not sure but this is my guess at where the error could be coming from

Let me know.

If it’s just isn’t working and you can’t work it out, I would just delete each transformation from the end backwards. Then just build it up again.

I do this often. It’s one of the great things about the query editor.


#3

Hi Sam,

Thanks for the reply. I tried deleting a row in the advanced editor code but still gave me an error. I then decided to click on wheel(?) next to line in applied steps (image below) and that provided the list of columns to keep (which was the step in advanced editor). So I checked the Inv Price field and everything worked out fine from there. BI and Query Editor are so versatile compared to doing in Excel !! Thanks again.

Applied%20Steps


#4

Super stuff. Glad it’s sorted.