Latest Enterprise DNA Initiatives

Beta Connectors not available in PBI Desktop

I am using remote desktop to access a machine with Power BI Desktop installed (64-Bit December 2020).

I am not able to see any of the Beta Connectors, even though I have changed the security settings for Data extensions.

On my local machine with the same settings, I am able to see the Beta connectors. (I’m specifically looking for the TIBCO connector.)

Note that the remote machine is not connected to the Internet. Do you have any suggestions to remedy this?

Remote machine:


Data Extensions

My machine:

@DeanJ If remote machine is not connected to Internet, then how are you able to connect to that machine in the first place?

To clarify, it allows for very limited connections like remote desktop via VPN .

I can’t use it to sign in to Power BI Desktop for example or to download updates, download visuals, go to any websites, etc.

I was wondering if not being able to sign in made a difference. Not sure what else it could be… When I sign out of my machine I am still able to see the beta connections.

Keeping the internet issue aside the options you are getting in the remote machine are much less than what I have on my version of PBID. Is there a possibility that it is an older version ( do a re-check ) or maybe the report server version, I am not sure but worth checking.

thanks @AntrikshSharma I will take another look and post some screenshots.

I got a little more information- here is the PBI version of the remote machine:
About

It does have some Beta connections under Online Services, but they are still different than what I have on my local machine.

Remote machine:

Local machine:

Also, I tried to export PBIDS, but it did not work.
Export PBIDS

When I copy the M query from the local machine to the remote one using advanced editor, I get the error below- I am going to look into that further.
expressionerror

using this page:
https://answers.microsoft.com/en-us/msoffice/forum/all/power-query-get-transform-the-import-xxx-matches/8335bba2-9c7b-47d8-a5d5-1ece1c9f9c4a

I might close this out because I think it has something to do with windows permissions. The last thing I did was verify that TIBCO.pqx was installed on both machines and it was.

Hi @DeanJ, did the response provided by @AntrikshSharma help you solve your query? If not, how far did you get and what kind of help you need further? If yes, kindly mark as solution the answer that solved your query. Thanks!