Latest Enterprise DNA Initiatives

Apply Query Changes fail

Bit of a weird issue. I have made changes to 6 queries. These all have a column with the same name (product id).

When I apply the changes it fails. The message contains the yellow warning sign and the message says

The name ‘product id’ is already used for a column on table ‘Sales’. Choose a different name.

I am currently working on fixing this but not sure what caused it or why. I have multiple columns that appear in more than one table. All of my joins have the same column in the two joined tables.

So far I have

  1. renamed the offending column on the Sales table - no change in the error message.
  2. Changed the data type as I noticed on one query it was text and another ABC123 - which I assume is alphanumeric or general.

Any idea why this message is happening?

Cheers
E

I noticed that ghe relationship view has product id and product id2 in the sales view. Additionally there is a red triangle next to the column product id.

I have deleted the product id column and am in the process of applying the changes.

Hoping this will help. I dont think product id is used in any dax calcs so I dont think that is the issue.

Thanks
E

Hi @ells. To help the forum members visualize and investigate your issue, can you post a work-in-progress PBIX (with sample or masked data, if necessary), along with a screenshot of what things look like right before the error, a screenshot of the error itself, and a marked-up screenshot of what you’re desired outcome would be?
Greg

Can do some of that.
Cant do the PBIX as sensitive
before the error there are six tables refreshing
then we get six tables erroring with the description above.

Can post some screenshots etc
Thanks
E

Hi @ells. Can you create a small PBIX model using made-up data that illustrates the problem and post that?
Greg

@Greg
If I could give you something close enough I really would. It really would make an accurate diagnosis but I cant and to hide all of the sensitive items would make it look nothing like the PBIX file I have.
To cut a long story short it seems like power BI got a little confused.
In the relationship window we could see Product id and Product id2. I had changes waiting for 6 tables.

When I went to apply the changes they all complained with the same error. ! including the table that did not have product id.

As the error pointed to product id in the sales table I removed that column.

I went to apply the changes and we got another error - nothing to do with the first error.

I changed nothing and refreshed the data in that table.

Everything seems ok now.

I think in future I will change one query at a time and then close and apply.

Just wish I knew what happened to cause the issue. Its not the first time this has happened.

Thanks
E

@ells I’m glad things are OK now … yup, one-at-a-time (then close and apply) is a good practice … I use it all the time.
Greg

2 Likes

Hi @ells, did the response provided by @Greg help you solve your query? If not, how far did you get and what kind of help you need further? If yes, kindly mark the thread as solved. Thanks!