Latest Enterprise DNA Initiatives


Sharepoint Folder Option

That is how I also provided.But not working

I am trying to connect to the SharePoint Folder for the fist time.
Its not in my existing data source list, because I have not even connected.
Im going to New Source – SharePoint Folder —Pasting the link and is throwing error while pasting…Attached screenshotCapture%203

Hi @Anu,

Could you display the complete link? Maybe you can blurr some parts.

Daniel

When you connect to a SharePoint folder, you can’t put the entire path. Only the root. So in your case, the site URL would start at https and end with .com.

If that doesn’t work – instead of going to Get Data --> SharePoint Folder, you could also try connecting via Get Data --> Web and pasting the entire URL there.

For both options if you still get the error message of “Access to the resource is forbidden.” you should reference the second link I previously sent you as this would indicate that the issue is credential related.

Thank you,
DT

So how to mention Subfolders?
https://abc.sharpoint.com/subfolder1/subfolder2 ?

My aim is to connect to the folder , so that I combine whatever files are coming in that folder(of same structure)

Once you successfully connect to the root URL, and get past the credentialing, you should be able to see all of the files from all of the folders that you have access to on that specific site.
https://powerbi.microsoft.com/pt-br/blog/combining-excel-files-hosted-on-a-sharepoint-folder/

If the above doesn’t work for your needs, I would suggest simply using the basic web connector and inputting the URL to your SharePoint folder.

1 Like

I tried using web.
Get data —Web—

these are different ways that I tried and the errors that I got
1.
Capture1
Capture2


Capture4


Yes, these are the credentialing issues that I expected you would have. Some of the links that I have previously shared may help to resolve these credentialing issues.

Thank you

I have read through both the links,

  1. I am already using Organizational Account to login as site is O365
  2. I am using latest version of Power BI
  3. The below method of clearing permission cannot be applied for me because I am not even able to connect to the site. And it doesnt appear in this list

Hi Anu-
I am not sure what else you can try. I will continue to research and will get back to you should I come across something. My apologies.

DT

It is not clear whether you tried connecting using “SharePoint Folder” by providing the URL to the root level of the site. Did you already try that? Once you establish the connection to the site, the data that is imported consists of a listing of all the files on that SharePoint site. You then use PowerQuery to filter that list down to the file(s) that you want to extract data from. After that, you use PowerQuery to extract the data from those files and manipulate that data as needed. It works perfectly, but it is not intuitive if it is the first time you have done it.

Yes ,I tried that


Capture12

I have seen in sites saying ,“Clear Permissions” for data source, But it is not even appearing in the data source list, coz this error occurs while trying to connect,

My connections only work when connecting to the root of the site I want to access. For example,

https://xyz.sharepoint.com/sites/mysite

By mentioning sub folders you mean? And this is using SharePoint Folder option?

Hi @Anu,

DaveC is right…

In the Power Query Editor you will have to filter out the right folder in the column with the path. It’s a little bit strange that the SharePoint folder connection doesn’t accept the specific URL to the folder directly, but it’s just the way it is on this moment.

Daniel

There are no subfolders included in the URL. The sample URL I gave above is the root of that particular SharePoint site. A SharePoint site URL consists of the following:

Protocol: https://
Server: xyz.sharepoint.com
Sites Folder: sites
Site Root Level Folder: mysite

I guess you could call sites and mysite subfolders in the context of the server, but mysite is the root level folder of the SharePoint site–using my example, of course. Your URLs will be different, but the basic structure should be the same.

Hi @Anu, we’ve noticed that no response has been received from you since February 02, 2020. We just want to check if you still need further help with this post? In case there won’t be any activity on it in the next few days, we’ll be tagging this post as Solved. If you have a follow question or concern related to this topic, please remove the Solution tag first by clicking the three dots beside Reply and then untick the check box. Thanks!