Latest Enterprise DNA Initiatives

Problem with giving permission to App

Hi All,

Would be grateful if anyone could help me solve the following issue.

I have several core datasets, all saved in a workspace with restricted access to a small team.

When I then publish an app for example to the sales team (who don’t have access to the core datasets in the workspace) the data in the report is not coming through.

Any ideas, or suggestions on how this should be better done?

Thanks so much

Hi @mazhowitt

You need to give access of underlying dataset for them. Make a group email with all the users who needs to have access and give access of dataset to that group.


Thank you. Is there no other way?
I have payroll datasets and I don’t want everyone having access to these.

Hi @mazhowitt. I don’t think you’ll be able to get around the report consumers needing to have read access to the underlying data in a report. Perhaps create additional curated datasets from your payroll datasets that only have non-sensitive data, then create the reports to be shared from these new datasets?

Thank you, I’ve found a solution. I can grant them access to the dataset, without giving them access to the workspace.

Glad that you found a solution to your problem @mazhowitt.

Kindly mark as solution the answer that helped you come up with an answer to your query. Thanks!

Hi @mazhowitt, we’ve noticed that no response has been received from you since the 1st of June. We just want to check if you still need further help with this post? In case there won’t be any activity on it in the next few days, we’ll be tagging this post as Solved.

Hi @mazhowitt, due to inactivity, a response on this post has been tagged as “Solution”. If you have a follow question or concern related to this topic, please remove the Solution tag first by clicking the three dots beside Reply and then untick the check box.

Kindly take time to answer the Enterprise DNA Forum User Experience Survey, we hope you’ll give your insights on how we can further improve the Support forum. Thanks!