Actuals/Budgets: row context not getting detected

Good morning. Could someone please help me with the dax for Budgets? It is not picking up the context of month. I know my model structure is not ideal (for example I’d really prefer a “Actuals/Budget” column and have everything in one table). But unfortunately, this is what I have to work with.

Budget:= CALCULATE( SUMX(Budgets, Budgets[BudgetAmount]) )

no_month_context

@michellepace Your Date table is not connected to your Budget table that’s causing a filter propagation issue. Try connecting the Dates with Dates in Budget table. Moreover, you can also look at the following video by @JarrettM to build relationship in your model

@michellepace,

Here are two sets of eDNA search results that will be helpful to you in resolving this problem. While I can’t say for certain in this case, since you provided only a general data model rather than specific data, typically in this situation the challenge is dealing with the granularity mismatch between actual data (typically on a daily level) and budgets (typically on a monthly, quarterly or even annual basis).

The dynamic budget allocation methodology from the first set of videos will allow you to resolve this granularity problem, and the second set will walk through how to use TREATAS to implement the virtual relationships needed to achieve the result you want.

I hope this is helpful.

– Brian
https://forum.enterprisedna.co/search?expanded=true&q=%23enterprise-dna-online%20budget%20allocation

https://forum.enterprisedna.co/search?expanded=true&q=%23enterprise-dna-online%20budget%20actual

Hi @michellepace, did the response provided by @BrianJ help you solve your query? If not, how far did you get and what kind of help you need further? If yes, kindly mark the thread as solved. Thanks!

Hi @michellepace, we’ve noticed that no response has been received from you since the 16th of November. We just want to check if you still need further help with this post? In case there won’t be any activity on it in the next few days, we’ll be tagging this post as Solved. If you have a follow question or concern related to this topic, please remove the Solution tag first by clicking the three dots beside Reply and then untick the checkbox. Thanks!